Press J to jump to the feed. Press question mark to learn the rest of the keyboard shortcuts
79
ArchivedStickied postModerator of r/bugs

As the sidebar says:

Found some insect that blows your mind? This is not the place for it. Try /r/whatsthisbug or /r/insects instead.

79
18 comments
3

I had 777 karma for one day, and I made a post, suddenly I have my karma doubled. It's 1554 now. I thought my post exploded, but it just has 10 upvotes or something. Is this really intended because of the number 777? Or what is going on?

3
comment
1

Ever since the update I've been having this issue where, when I post a comment on a thread (and it doesn't happen every time but it's been happening more and more lately which is why I'm here) the page reloads and then suddenly the page starts scrolling wildly up and down and all over the place. Often I end up abandoning a post I was having fun reading because when this happens I usually completely lose my place and have to reload the page again and then scroll, and scroll, and scroll to find where I was at in the comments when it happened.

I've updated Chrome and it is up to date but this issue happened both before and after a recent update. It has not happened on any other website. It isn't a mouse issue (I just replaced my mouse and it happened with the old and the new). And lastly I've noticed that it happens more often on posts with a lot of comments and even more often if I've expanded comments beyond what is shown initially when the post loads. The more comments I expand the more likely it is to happen when I post a comment myself (from my perspective).

1
comment
1

I have an account where I test a bot with, /u/Cheet4hsTestBot. When I created that account, I removed all subscriptions, apart from /r/announcements apparently.
That account is also an approved submitter in my private subreddit and also subscribed to it.

When I visit reddit.com with the bot, I usually get a completely empty front page, as seen in this picture with one tab in the good, and one in the new design, side by side. With the only subscriptions being two subs that haven't seen any posts in the last two weeks, it's understandably empty.
But as soon as I remove the approved submitter state of the bot account, this happens when I try to load the front page.
In the good design, I simply get a "You broke reddit" message.
In the new design, it shows me /r/popular and claims I'm not logged in. On clicking the "log in" button, a modal pops up that tells me I'm already logged in and proceeds to reload the page. Unsurprisingly it does not log me in.
I reproduced this in Edge, with only uBlock Origin being active.

I can resolve this by either subscribing to a more active subreddit, or by unsubscribing from the private sub prior to removing access. One cannot unsubscribe without having access, apparently.

What I actually would have expected is that the displayed frontpage does not change, whether or not I have access to a specific subreddit.

1
comment
2

As an example of what just happened: I changed my password and tried to enable 2fa.

For the first 20 seconds or so, the 2fa enabling endpoint was telling me my new password was incorrect. Keeping it in the field and hitting "okay" after 20 seconds magically worked.

I get that it's a pain to have these things synchronized, but perhaps such a task should be on the same server then?

2
comment
3

All the comment shows is that it was removed, and the thread it was originally from. No unsave button.

3
comment
1

Pretty much the title, whenever I open chat messages on mobile (iPhone 7, IOS12.0, reddit version 4.16.0, most updated) the entire app completely freezes and I have to restart it. Have not been able to access chats for a little while now.

1
comment
2

UPDATE: It seems to be fixed now.

At the moment, when I click the Snoo at the top left corner of the page, which should load this page, I'm redirected to a page that says "you crashed reddit."

2
comment
1

I use the old version of reddit, but the chat icon is missing, yet it shows up on the new version of reddit, which I don't use. How do I get the chat icon back on old version of reddit?

1
comment
1

The black header bar is hiding the posts on scrolling with keyboard button.

It is situation before pressing page down button.

https://i.redd.it/fjsiauhrzng11.png

Now once I press the page down button. The some part of post of 'V2Blast' is hidden behind The black Header.

https://i.redd.it/mo2628b50og11.png

It is very annoying while surfing through keyboard. Please do something.

1
comment
4

Nothing happens when I click the opt out of redesign. There is no error in the browser console. It appears that the button does nothing.

4
comment
2

As the title says, I am getting 404 error when calling with POST method

2
comment
2

Hi. When you post or comment, you automatically upvote it, but votes on your posts don't actually count.

Just now, the votes on a random half of my posts and comments suddenly disappeared. No idea why, and I know that they don't actually count, but it just seems odd to me, especially considering that only some of them were un-voted, and they seem random. And plus, there's the possibility that this glitch could occur on other people's comments and posts as well, and in that case it may actually affect the scores.

Thoughts?

2
18 comments
2

if you go to a user overview, such as http://old.reddit.com/user/nobody_import4nt

you would expect to see the old overview UI.

Instead you see the new UI. You have to manually add a /overview to the end of that URL to force it to old UI.

Why? I thought the whole point of the old domain was to avoid these changes.

2
2 comments
1

Any time I try to join a chat room on iPhone 7, iOS 12 the reddit app freezes for 30 seconds and then crashes.

1
comment
2

Please correct this. I see no way to disable chat either from users sending me chats. Hiding chat on my end is not a solution, as users think they're sending me chats and have an expectation to keep doing this.

2
comment
8

To reproduce:

Open random submission
Scroll down a bit (seems to not work on top comment)
Vote on comment repeatedly (keep clicking)
Page will reload, bumping you to the top

This also happens with a singular vote on occasion, which is how I found this.

Edit: Seems to be fixed?

8
6 comments
3

I have access permissions on /r/mildlyinteresting, and should be unable to see which posts have been approved. Via the API, I can (as seen in the Apollo reddit app).

3
comment
1

The checkout page to subscribe to Reddit Gold doesn't seem to work. I filled out my credit card info, clicked submit, and got this javascript error: `e is not defined`

https://i.redd.it/cfhafvyb0dg11.png

1
2 comments
2

Hi umm....not quite sure how to explain this but for some reason Tumblr image posts are being auto hidden on subreddits.

Like here's a screenshot of the new posts on r/Persona5 from my perspective when I'm logged in:

https://imgur.com/sTjrTIk

And here's one of the new posts when I'm logged out:

https://imgur.com/0UGX5Gm

Notice how my two posts, which were Tumblr links, are hidden from view.

I tested this out on a few other subreddits and got the same results. Twitter links or direct image posts weren't being auto hidden, but for some reason Tumblr Image links are.

2
comment
2

Feature in Reddit premium where they allow you to filter, but this result set lists subs in random order, and also contains subs with no posts in them (these should be removed).

2
comment
2

Hi. I use Reddit app on my iPhone X. When I open links in posts, for example Instagram, web page in Reddit app is working, but links to install the applications is not working. Steps (open web pages in Reddit app on iPhone): - visit Instagram webpage - press GET button at the top or AppStore link - them are not working - visit Imgur.com - press Open in App - you will be redirected to iTunes - press "Get the App" - nothing happens - visit Google Hangouts - press "App Store" link - nothing happens In Safari browser all is working properly. PS: to find this pages I found the link to the Google frontpage.

2
comment
1

So, I'd just like to say, when ever I go to settings and try to go to notifications the app just crashes. I'm not sure if this happens for anyone else but it happens every time for me. It's not really possible to a screen shot of it so I don't have much to help prove it's a bug.

I use IOS, and I use the Reddit App.

1
5 comments
Community Details

3.2k

Subscribers

18

Online

Have you found a bug with specifically reddit itself? We only handle reddit specific issues here.

Create Post
Insects, Spiders, and Bugs
r/insects

8,093 subscribers

r/whatsthisbug

91,290 subscribers

Other Help Subreddits
r/help

46,977 subscribers

r/ideasfortheadmins

9,424 subscribers

r/redditmobile

54,865 subscribers

r/modhelp

17,833 subscribers

r/modsupport

10,643 subscribers

r/needamod

11,144 subscribers

r/mobileweb

589 subscribers

r/bugs Rules
1.
Don't post insects, spiders, or other creepers
2.
Be excellent to each other.
3.
Don't publicly post security issues.
4.
Include context: when, what, where, how?
5.
Ask in r/help for help using reddit.
Cookies help us deliver our Services. By using our Services or clicking I agree, you agree to our use of cookies. Learn More.