Press J to jump to the feed. Press question mark to learn the rest of the keyboard shortcuts
10
Posted byMeow 馃悎馃悎Meow 馃惐馃惐 Meow Meow馃嵑馃悎馃惐Meow A+!1 year ago
Archived

Super Fun RIPv2 Challenge

So I have been reading through Lammle's CCNA books in my spare time and thought of a super fun challenge for people who have read the ICND2 or at least have a good grasp of the topics.

The above topology has 20 routers connected in a line one after the other. Config wise each router just has interface IPs, a loopback address, and basic RIP config for all networks so you can make this with PT/GNS3/VIRL etc.

The challenge to those who accept is to configure the network in such a way where R01 will see all other router's loopback routes via RIP.

Rules: Only two static routes are allowed!

Bonus points if you decide to use eBGP.

Winners will get.....a kitty gif!

26 comments
79% Upvoted
This thread is archived
New comments cannot be posted and votes cannot be cast
level 1
Meow 馃悎馃悎Meow 馃惐馃惐 Meow Meow馃嵑馃悎馃惐Meow A+!Original Poster2 points1 year agoedited 1 year ago
level 1
A+, Net +,CCNA R&S, JNCIA-Junos, NP Switch2 points1 year ago

First 15 routers will use all RIP, then the last 5 I'll use another protocol (BGP or static route) and redistribute! Im lazy

level 2
Meow 馃悎馃悎Meow 馃惐馃惐 Meow Meow馃嵑馃悎馃惐Meow A+!Original Poster1 point1 year ago

There is no redistribution in CCNA!

level 3
A+, Net +,CCNA R&S, JNCIA-Junos, NP Switch2 points1 year ago

hey you never said I couldn't do redistribution

level 4
Meow 馃悎馃悎Meow 馃惐馃惐 Meow Meow馃嵑馃悎馃惐Meow A+!Original Poster2 points1 year ago

Fair enough

CAT!!!

level 3

I learnt the basic of redistribution in CCNA, perks of doing teacher-led instruction I guess.

level 3
CCNP Security & Route Switch1 point1 year ago

If you are going to use eBGP with RIP, you will need to redistribute RIP into BGP.

Alternatively, you could always use iBGP with a Route-Reflector to distribute the loopback addresses via BGP and RIP for the underlay protocol to the RR.

level 1
CCENTian2 points1 year ago

I see no Snakes and Ladders, this game sucks

level 1
CCNP Security & Route Switch2 points1 year ago

You could easily do RIP peering to the middle from each end. Once you meet in the middle, do an eBGP Peering between the middle routers.

Redistribute RIP into eBGP

level 1
CCNA RS/W, BCNP, BCvRE2 points1 year ago

I managed to get all the RIP routes in R1 via an AToM VC between R6 and R15, but my LDP sessions were flapping because GNS3 doesn't like that kind of stuff...

That was more fun that just an eBGP peering between R10 and R11.

level 2
Meow 馃悎馃悎Meow 馃惐馃惐 Meow Meow馃嵑馃悎馃惐Meow A+!Original Poster2 points1 year ago

Well that is one way to solve a CCNA level GRE challenge :)

CAT!!!

level 1
1 point1 year ago

Oh you

level 1
CCNA RS/W, BCNP, BCvRE1 point1 year ago

Just to be clear, we have to use RIP only? Or are we allowed to use other protocols as well (since you mention eBGP)?

level 2
Meow 馃悎馃悎Meow 馃惐馃惐 Meow Meow馃嵑馃悎馃惐Meow A+!Original Poster1 point1 year ago

R01 has to see the Loopback routes as RIP routes with the exception of two static routes if need be. BGP routes are allowed if you want to try that route.

level 3
CCNA RS/W, BCNP, BCvRE1 point1 year ago

My 7200 image doesn't support multicast GRE tunnels, I tried to shortcut 4-16 to get everyone via RIP, but no dice!

Offset-lists don't work in negative, that would've been fun!

So, I'm going to my apointment and I'll try a new solution after...

level 2
Meow 馃悎馃悎Meow 馃惐馃惐 Meow Meow馃嵑馃悎馃惐Meow A+!Original Poster1 point1 year ago

BTW BGP would be pretty painful to use as the solution :)

level 1
CCENT1 point1 year agoedited 1 year ago

If redistribution is off the table, I would run BGP on all routers and do network statements on each router to advertise the loopback addresses into BGP. Shouldn't need any static routes.

Example:

R1 Loopback: 20.0.0.1/32 聽

R1 int to R2: 30.0.0.1/30 聽

R1 bgp statement:

no auto-summary

network 20.0.0.1 mask 255.255.255.255

neighbor 30.0.0.2 remote-as 1

level 1
1 point1 year ago

You are trusting 'Counting to infinity' to determine hops that will demand time or bandwidth or both. Metric is 32 bits that has 1 - 15 hops for current metric and 16 will indicate that destination is unreachable. You get the first part address family bits for hops normally that is 16 which is used for hop count including first. If you can code program the second part of the entry table 'route tag' you can get 32 bits same as IP. Hard to program router but you can perhaps change the loopback address of 16th - 20th router to an address exacting 16th - 20th bit of the header to specifically 'route tag' bits. This bits may keep changing in the header so your Loopback IP must match always. You may get something there.

level 2

I thought the max hops was 30?

level 3
Meow 馃悎馃悎Meow 馃惐馃惐 Meow Meow馃嵑馃悎馃惐Meow A+!Original Poster1 point1 year ago

Nope max hops is 15

level 1
CCENT1 point1 year ago

I used PT 7.0 to do this exercise. The connection from Router 10 <-> 11 was where I made the split between the two sets of routers. RIP passive interface on that connection with the joining interfaces as default route, propagated via RIP to the other routers in each segment. 2 static routes, RIP for all other routes.

Proof:

Also, make my kitty a good one because

Also, haven't read past ICND 101 and kept my file so I could make it work with BGP eventually.

C:\>tracert 20.20.20.20

Tracing route to 20.20.20.20 over a maximum of 30 hops: 

  1   0 ms      0 ms      0 ms      201.0.0.1
  2   0 ms      0 ms      0 ms      101.0.0.2
  3   0 ms      0 ms      0 ms      102.0.0.2
  4   0 ms      0 ms      0 ms      103.0.0.2
  5   0 ms      1 ms      0 ms      104.0.0.2
  6   0 ms      0 ms      1 ms      105.0.0.2
  7   0 ms      0 ms      0 ms      106.0.0.2
  8   0 ms      0 ms      0 ms      107.0.0.2
  9   0 ms      0 ms      0 ms      108.0.0.2
  10   23 ms     0 ms      10 ms     109.0.0.2
  11   *         10 ms     11 ms     110.0.0.2
  12   11 ms     10 ms     11 ms     111.0.0.2
  13   10 ms     10 ms     10 ms     112.0.0.2
  14   10 ms     10 ms     10 ms     113.0.0.2
  15   10 ms     11 ms     11 ms     114.0.0.2
  16   10 ms     10 ms     10 ms     115.0.0.2
  17   11 ms     10 ms     11 ms     116.0.0.2
  18   10 ms     11 ms     12 ms     117.0.0.2
  19   10 ms     10 ms     10 ms     118.0.0.2
  20   10 ms     21 ms     11 ms     20.20.20.20


R1>show ip route
.... Header stuff trimmed out .....

Gateway of last resort is 101.0.0.2 to network 0.0.0.0

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback1
     2.0.0.0/32 is subnetted, 1 subnets
R       2.2.2.2 [120/1] via 101.0.0.2, 00:00:00, FastEthernet4/0
     3.0.0.0/32 is subnetted, 1 subnets
R       3.3.3.3 [120/2] via 101.0.0.2, 00:00:00, FastEthernet4/0
     4.0.0.0/32 is subnetted, 1 subnets
R       4.4.4.4 [120/3] via 101.0.0.2, 00:00:00, FastEthernet4/0
     5.0.0.0/32 is subnetted, 1 subnets
R       5.5.5.5 [120/4] via 101.0.0.2, 00:00:00, FastEthernet4/0
     6.0.0.0/32 is subnetted, 1 subnets
R       6.6.6.6 [120/5] via 101.0.0.2, 00:00:00, FastEthernet4/0
     7.0.0.0/32 is subnetted, 1 subnets
R       7.7.7.7 [120/6] via 101.0.0.2, 00:00:00, FastEthernet4/0
     8.0.0.0/32 is subnetted, 1 subnets
R       8.8.8.8 [120/7] via 101.0.0.2, 00:00:00, FastEthernet4/0
     9.0.0.0/32 is subnetted, 1 subnets
R       9.9.9.9 [120/8] via 101.0.0.2, 00:00:00, FastEthernet4/0
     10.0.0.0/32 is subnetted, 1 subnets
R       10.10.10.10 [120/9] via 101.0.0.2, 00:00:00, FastEthernet4/0
     101.0.0.0/30 is subnetted, 1 subnets
C       101.0.0.0 is directly connected, FastEthernet4/0
     102.0.0.0/30 is subnetted, 1 subnets
R       102.0.0.0 [120/1] via 101.0.0.2, 00:00:00, FastEthernet4/0
     103.0.0.0/30 is subnetted, 1 subnets
R       103.0.0.0 [120/2] via 101.0.0.2, 00:00:00, FastEthernet4/0
     104.0.0.0/30 is subnetted, 1 subnets
R       104.0.0.0 [120/3] via 101.0.0.2, 00:00:00, FastEthernet4/0
     105.0.0.0/30 is subnetted, 1 subnets
R       105.0.0.0 [120/4] via 101.0.0.2, 00:00:00, FastEthernet4/0
     106.0.0.0/30 is subnetted, 1 subnets
R       106.0.0.0 [120/5] via 101.0.0.2, 00:00:00, FastEthernet4/0
     107.0.0.0/30 is subnetted, 1 subnets
R       107.0.0.0 [120/6] via 101.0.0.2, 00:00:00, FastEthernet4/0
     108.0.0.0/30 is subnetted, 1 subnets
R       108.0.0.0 [120/7] via 101.0.0.2, 00:00:00, FastEthernet4/0
     109.0.0.0/30 is subnetted, 1 subnets
R       109.0.0.0 [120/8] via 101.0.0.2, 00:00:00, FastEthernet4/0
     110.0.0.0/30 is subnetted, 1 subnets
R       110.0.0.0 [120/9] via 101.0.0.2, 00:00:00, FastEthernet4/0
C    201.0.0.0/24 is directly connected, FastEthernet0/0
R    202.0.0.0/24 [120/1] via 101.0.0.2, 00:00:00, FastEthernet4/0
R    203.0.0.0/24 [120/2] via 101.0.0.2, 00:00:00, FastEthernet4/0
R    204.0.0.0/24 [120/3] via 101.0.0.2, 00:00:00, FastEthernet4/0
R    205.0.0.0/24 [120/4] via 101.0.0.2, 00:00:00, FastEthernet4/0
R    206.0.0.0/24 [120/5] via 101.0.0.2, 00:00:00, FastEthernet4/0
R    207.0.0.0/24 [120/6] via 101.0.0.2, 00:00:00, FastEthernet4/0
R    208.0.0.0/24 [120/7] via 101.0.0.2, 00:00:00, FastEthernet4/0
R    209.0.0.0/24 [120/8] via 101.0.0.2, 00:00:00, FastEthernet4/0
R    210.0.0.0/24 [120/9] via 101.0.0.2, 00:00:00, FastEthernet4/0
R*   0.0.0.0/0 [120/9] via 101.0.0.2, 00:00:00, FastEthernet4/0



R20#show ip route
.... Header stuff trimmed out .....
Gateway of last resort is 119.0.0.1 to network 0.0.0.0

     11.0.0.0/32 is subnetted, 1 subnets
R       11.11.11.11 [120/9] via 119.0.0.1, 00:00:09, FastEthernet4/0
     12.0.0.0/32 is subnetted, 1 subnets
R       12.12.12.12 [120/8] via 119.0.0.1, 00:00:09, FastEthernet4/0
     13.0.0.0/32 is subnetted, 1 subnets
R       13.13.13.13 [120/7] via 119.0.0.1, 00:00:09, FastEthernet4/0
     14.0.0.0/32 is subnetted, 1 subnets
R       14.14.14.14 [120/6] via 119.0.0.1, 00:00:09, FastEthernet4/0
     15.0.0.0/32 is subnetted, 1 subnets
R       15.15.15.15 [120/5] via 119.0.0.1, 00:00:09, FastEthernet4/0
     16.0.0.0/32 is subnetted, 1 subnets
R       16.16.16.16 [120/4] via 119.0.0.1, 00:00:09, FastEthernet4/0
     17.0.0.0/32 is subnetted, 1 subnets
R       17.17.17.17 [120/3] via 119.0.0.1, 00:00:09, FastEthernet4/0
     18.0.0.0/32 is subnetted, 1 subnets
R       18.18.18.18 [120/2] via 119.0.0.1, 00:00:09, FastEthernet4/0
     19.0.0.0/32 is subnetted, 1 subnets
R       19.19.19.19 [120/1] via 119.0.0.1, 00:00:09, FastEthernet4/0
     20.0.0.0/32 is subnetted, 1 subnets
C       20.20.20.20 is directly connected, Loopback1
     111.0.0.0/30 is subnetted, 1 subnets
R       111.0.0.0 [120/8] via 119.0.0.1, 00:00:09, FastEthernet4/0
     112.0.0.0/30 is subnetted, 1 subnets
R       112.0.0.0 [120/7] via 119.0.0.1, 00:00:09, FastEthernet4/0
     113.0.0.0/30 is subnetted, 1 subnets
R       113.0.0.0 [120/6] via 119.0.0.1, 00:00:09, FastEthernet4/0
     114.0.0.0/30 is subnetted, 1 subnets
R       114.0.0.0 [120/5] via 119.0.0.1, 00:00:09, FastEthernet4/0
     115.0.0.0/30 is subnetted, 1 subnets
R       115.0.0.0 [120/4] via 119.0.0.1, 00:00:09, FastEthernet4/0
     116.0.0.0/30 is subnetted, 1 subnets
R       116.0.0.0 [120/3] via 119.0.0.1, 00:00:09, FastEthernet4/0
     117.0.0.0/30 is subnetted, 1 subnets
R       117.0.0.0 [120/2] via 119.0.0.1, 00:00:09, FastEthernet4/0
     118.0.0.0/30 is subnetted, 1 subnets
R       118.0.0.0 [120/1] via 119.0.0.1, 00:00:09, FastEthernet4/0
     119.0.0.0/30 is subnetted, 1 subnets
C       119.0.0.0 is directly connected, FastEthernet4/0
R    211.0.0.0/24 [120/9] via 119.0.0.1, 00:00:09, FastEthernet4/0
R    212.0.0.0/24 [120/8] via 119.0.0.1, 00:00:09, FastEthernet4/0
R    213.0.0.0/24 [120/7] via 119.0.0.1, 00:00:09, FastEthernet4/0
R    214.0.0.0/24 [120/6] via 119.0.0.1, 00:00:09, FastEthernet4/0
R    215.0.0.0/24 [120/5] via 119.0.0.1, 00:00:09, FastEthernet4/0
R    216.0.0.0/24 [120/4] via 119.0.0.1, 00:00:09, FastEthernet4/0
R    217.0.0.0/24 [120/3] via 119.0.0.1, 00:00:09, FastEthernet4/0
R    219.0.0.0/24 [120/1] via 119.0.0.1, 00:00:09, FastEthernet4/0
C    220.0.0.0/24 is directly connected, FastEthernet0/0
R*   0.0.0.0/0 [120/9] via 119.0.0.1, 00:00:09, FastEthernet4/0
level 2
Meow 馃悎馃悎Meow 馃惐馃惐 Meow Meow馃嵑馃悎馃惐Meow A+!Original Poster1 point1 year ago

Close but R01 needs to see all the loopbacks! No defaults!

Though kitty for the effort

level 3
CCENT1 point1 year ago

I... I cast OSPF - at the darkness!

level 3
CCENT1 point1 year ago

I got it to work using RIP <-> OSPF | R10 | <->| R11 | OSPF <->RIP

Of course now it thinks that multiple routers are 9 hops away from the furthest point but hey - it works. I'd be curious to find out the real solution.

	R1>show ip route
	..... Removed description header .....
	Gateway of last resort is not set
	
	     1.0.0.0/32 is subnetted, 1 subnets
	C       1.1.1.1 is directly connected, Loopback1
	     2.0.0.0/32 is subnetted, 1 subnets
	R       2.2.2.2 [120/1] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     3.0.0.0/32 is subnetted, 1 subnets
	R       3.3.3.3 [120/2] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     4.0.0.0/32 is subnetted, 1 subnets
	R       4.4.4.4 [120/3] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     5.0.0.0/32 is subnetted, 1 subnets
	R       5.5.5.5 [120/4] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     6.0.0.0/32 is subnetted, 1 subnets
	R       6.6.6.6 [120/5] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     7.0.0.0/32 is subnetted, 1 subnets
	R       7.7.7.7 [120/6] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     8.0.0.0/32 is subnetted, 1 subnets
	R       8.8.8.8 [120/7] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     9.0.0.0/32 is subnetted, 1 subnets
	R       9.9.9.9 [120/8] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     10.0.0.0/32 is subnetted, 1 subnets
	R       10.10.10.10 [120/9] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     11.0.0.0/32 is subnetted, 1 subnets
	R       11.11.11.11 [120/10] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     12.0.0.0/32 is subnetted, 1 subnets
	R       12.12.12.12 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     13.0.0.0/32 is subnetted, 1 subnets
	R       13.13.13.13 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     14.0.0.0/32 is subnetted, 1 subnets
	R       14.14.14.14 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     15.0.0.0/32 is subnetted, 1 subnets
	R       15.15.15.15 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     16.0.0.0/32 is subnetted, 1 subnets
	R       16.16.16.16 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     17.0.0.0/32 is subnetted, 1 subnets
	R       17.17.17.17 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     18.0.0.0/32 is subnetted, 1 subnets
	R       18.18.18.18 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     19.0.0.0/32 is subnetted, 1 subnets
	R       19.19.19.19 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     20.0.0.0/32 is subnetted, 1 subnets
	R       20.20.20.20 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     101.0.0.0/30 is subnetted, 1 subnets
	C       101.0.0.0 is directly connected, FastEthernet4/0
	     102.0.0.0/30 is subnetted, 1 subnets
	R       102.0.0.0 [120/1] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     103.0.0.0/30 is subnetted, 1 subnets
	R       103.0.0.0 [120/2] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     104.0.0.0/30 is subnetted, 1 subnets
	R       104.0.0.0 [120/3] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     105.0.0.0/30 is subnetted, 1 subnets
	R       105.0.0.0 [120/4] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     106.0.0.0/30 is subnetted, 1 subnets
	R       106.0.0.0 [120/5] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     107.0.0.0/30 is subnetted, 1 subnets
	R       107.0.0.0 [120/6] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     108.0.0.0/30 is subnetted, 1 subnets
	R       108.0.0.0 [120/7] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     109.0.0.0/30 is subnetted, 1 subnets
	R       109.0.0.0 [120/8] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     110.0.0.0/30 is subnetted, 1 subnets
	R       110.0.0.0 [120/9] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     111.0.0.0/30 is subnetted, 1 subnets
	R       111.0.0.0 [120/10] via 101.0.0.2, 00:00:26, FastEthernet4/0
	     112.0.0.0/30 is subnetted, 1 subnets
	R       112.0.0.0 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     113.0.0.0/30 is subnetted, 1 subnets
	R       113.0.0.0 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     114.0.0.0/30 is subnetted, 1 subnets
	R       114.0.0.0 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     115.0.0.0/30 is subnetted, 1 subnets
	R       115.0.0.0 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     116.0.0.0/30 is subnetted, 1 subnets
	R       116.0.0.0 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     117.0.0.0/30 is subnetted, 1 subnets
	R       117.0.0.0 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     118.0.0.0/30 is subnetted, 1 subnets
	R       118.0.0.0 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	     119.0.0.0/30 is subnetted, 1 subnets
	R       119.0.0.0 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	C    201.0.0.0/24 is directly connected, FastEthernet0/0
	R    202.0.0.0/24 [120/1] via 101.0.0.2, 00:00:26, FastEthernet4/0
	R    203.0.0.0/24 [120/2] via 101.0.0.2, 00:00:26, FastEthernet4/0
	R    204.0.0.0/24 [120/3] via 101.0.0.2, 00:00:26, FastEthernet4/0
	R    205.0.0.0/24 [120/4] via 101.0.0.2, 00:00:26, FastEthernet4/0
	R    206.0.0.0/24 [120/5] via 101.0.0.2, 00:00:26, FastEthernet4/0
	R    207.0.0.0/24 [120/6] via 101.0.0.2, 00:00:26, FastEthernet4/0
	R    208.0.0.0/24 [120/7] via 101.0.0.2, 00:00:26, FastEthernet4/0
	R    209.0.0.0/24 [120/8] via 101.0.0.2, 00:00:26, FastEthernet4/0
	R    210.0.0.0/24 [120/9] via 101.0.0.2, 00:00:26, FastEthernet4/0
	R    211.0.0.0/24 [120/10] via 101.0.0.2, 00:00:26, FastEthernet4/0
	R    212.0.0.0/24 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	R    213.0.0.0/24 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	R    214.0.0.0/24 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	R    215.0.0.0/24 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	R    216.0.0.0/24 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	R    217.0.0.0/24 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0
	R    219.0.0.0/24 [120/9] via 101.0.0.2, 00:00:18, FastEthernet4/0


	R10#show run | be ospf
	router ospf 1
	log-adjacency-changes
	redistribute rip subnets
	passive-interface FastEthernet0/0
	passive-interface FastEthernet4/0
	network 0.0.0.0 255.255.255.255 area 0
	neighbor 110.0.0.2
	!
	router rip
	version 2
	redistribute ospf 1 metric 0
	passive-interface FastEthernet0/0
	network 10.0.0.0
	network 109.0.0.0
	network 110.0.0.0
	network 210.0.0.0
	no auto-summary
    !


	R11#show run | be ospf
	router ospf 1
	log-adjacency-changes
	redistribute rip subnets
	passive-interface FastEthernet0/0
	passive-interface FastEthernet5/0
	network 0.0.0.0 255.255.255.255 area 0
	neighbor 110.0.0.1
	!
	router rip
	version 2
	redistribute ospf 1 metric 0
	passive-interface FastEthernet0/0
	network 11.0.0.0
	network 110.0.0.0
	network 111.0.0.0
	network 211.0.0.0
	no auto-summary
	!
level 1

Took me a bit to figure it out, then I realized R11 had all the routes since he's in the middle. So I just made a GRE tunnel from R1 to R11 and ran RIP over it. Pretty simple once you think about it.

R1:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Tunnel0
ip address 192.168.0.1 255.255.255.0
tunnel source FastEthernet1/0
tunnel destination 172.16.0.38

interface FastEthernet1/0
ip address 172.16.0.1 255.255.255.252
duplex auto
speed auto

router rip
version 2
network 1.0.0.0
network 192.168.0.0
no auto-summary

ip route 172.16.0.38 255.255.255.255 172.16.0.2

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

  1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks  

C 1.1.1.0/24 is directly connected, Loopback0
L 1.1.1.1/32 is directly connected, Loopback0
2.0.0.0/24 is subnetted, 1 subnets
R 2.2.2.0 [120/10] via 192.168.0.2, 00:00:09, Tunnel0
3.0.0.0/24 is subnetted, 1 subnets
R 3.3.3.0 [120/9] via 192.168.0.2, 00:00:09, Tunnel0
4.0.0.0/24 is subnetted, 1 subnets
R 4.4.4.0 [120/8] via 192.168.0.2, 00:00:09, Tunnel0
5.0.0.0/24 is subnetted, 1 subnets
R 5.5.5.0 [120/7] via 192.168.0.2, 00:00:09, Tunnel0
6.0.0.0/24 is subnetted, 1 subnets
R 6.6.6.0 [120/6] via 192.168.0.2, 00:00:09, Tunnel0
7.0.0.0/24 is subnetted, 1 subnets
R 7.7.7.0 [120/5] via 192.168.0.2, 00:00:09, Tunnel0
8.0.0.0/24 is subnetted, 1 subnets
R 8.8.8.0 [120/4] via 192.168.0.2, 00:00:09, Tunnel0
9.0.0.0/24 is subnetted, 1 subnets
R 9.9.9.0 [120/3] via 192.168.0.2, 00:00:09, Tunnel0
10.0.0.0/24 is subnetted, 1 subnets
R 10.10.10.0 [120/2] via 192.168.0.2, 00:00:09, Tunnel0
11.0.0.0/30 is subnetted, 1 subnets
R 11.11.11.0 [120/1] via 192.168.0.2, 00:00:09, Tunnel0
12.0.0.0/24 is subnetted, 1 subnets
R 12.12.12.0 [120/2] via 192.168.0.2, 00:00:09, Tunnel0
13.0.0.0/24 is subnetted, 1 subnets
R 13.13.13.0 [120/3] via 192.168.0.2, 00:00:09, Tunnel0
14.0.0.0/24 is subnetted, 1 subnets
R 14.14.14.0 [120/4] via 192.168.0.2, 00:00:09, Tunnel0
15.0.0.0/30 is subnetted, 1 subnets
R 15.15.15.0 [120/5] via 192.168.0.2, 00:00:09, Tunnel0
16.0.0.0/24 is subnetted, 1 subnets
R 16.16.16.0 [120/6] via 192.168.0.2, 00:00:09, Tunnel0
17.0.0.0/24 is subnetted, 1 subnets
R 17.17.17.0 [120/7] via 192.168.0.2, 00:00:09, Tunnel0
18.0.0.0/24 is subnetted, 1 subnets
R 18.18.18.0 [120/8] via 192.168.0.2, 00:00:09, Tunnel0
19.0.0.0/24 is subnetted, 1 subnets
R 19.19.19.0 [120/9] via 192.168.0.2, 00:00:09, Tunnel0
20.0.0.0/24 is subnetted, 1 subnets
R 20.20.20.0 [120/10] via 192.168.0.2, 00:00:09, Tunnel0
172.16.0.0/16 is variably subnetted, 21 subnets, 2 masks
C 172.16.0.0/30 is directly connected, FastEthernet1/0
L 172.16.0.1/32 is directly connected, FastEthernet1/0
R 172.16.0.4/30 [120/9] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.8/30 [120/8] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.12/30 [120/7] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.16/30 [120/6] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.20/30 [120/5] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.24/30 [120/4] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.28/30 [120/3] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.32/30 [120/2] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.36/30 [120/1] via 192.168.0.2, 00:00:09, Tunnel0
S 172.16.0.38/32 [1/0] via 172.16.0.2
R 172.16.0.40/30 [120/1] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.44/30 [120/2] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.48/30 [120/3] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.52/30 [120/4] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.56/30 [120/5] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.60/30 [120/6] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.64/30 [120/7] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.68/30 [120/8] via 192.168.0.2, 00:00:09, Tunnel0
R 172.16.0.72/30 [120/9] via 192.168.0.2, 00:00:09, Tunnel0
192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.0.0/24 is directly connected, Tunnel0
L 192.168.0.1/32 is directly connected, Tunnel0

level 2
Meow 馃悎馃悎Meow 馃惐馃惐 Meow Meow馃嵑馃悎馃惐Meow A+!Original Poster1 point1 year ago
Community Details

34.0k

Subscribers

145

Online

Create Post
r/ccna Rules
1.
No posting of illegal materials
2.
No posting of braindumps
3.
Be courteous and helpful
4.
Don't ask others to complete your labs
Cookies help us deliver our Services. By using our Services or clicking I agree, you agree to our use of cookies.Learn More.