Press J to jump to the feed. Press question mark to learn the rest of the keyboard shortcuts
2

Cant ping from host

I am trying to ping a printer in another Office, but cant do it from a host. I can ping it from the router it self.

Picture is for a overview not the real deal

Picture ---> (https://imgur.com/a/rPHE92A)

The Configuration:

Building configuration...

Current configuration : 1432 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Office3

!

boot-start-marker

boot system flash:c1700-advsecurityk9-mz.124-13b.bin

boot system slot1:c1700-advsecurityk9-mz.124-13b.bin

boot-end-marker

!

!

no aaa new-model

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.3.2

!

ip dhcp pool office3

import all

network 192.168.3.0 255.255.255.0

default-router 192.168.3.1

dns-server 8.8.8.8

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0

ip address 10.0.0.3 255.0.0.0

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface Vlan1

ip address 192.168.3.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Async1

no ip address

encapsulation slip

!

router rip

network 192.168.3.0

!

ip route 0.0.0.0 0.0.0.0 FastEthernet0 10.0.0.4

ip route 192.168.1.0 255.255.255.0 10.0.0.1

ip route 192.168.1.0 255.255.255.0 Vlan1 10.0.0.1

ip route 192.168.1.2 255.255.255.255 10.0.0.1

ip route 192.168.2.2 255.255.255.255 10.0.0.2

!

no ip http server

no ip http secure-server

ip nat inside source list 1 interface FastEthernet0 overload

!

access-list 1 permit any

!

control-plane

!

!

line con 0

line 1

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

login

!

end

36 comments
63% Upvoted
What are your thoughts? Log in or Sign uplog insign up
level 1

You need to give the separate office LAN’s a different /24 address and it will work

level 1

There is nowhere near enough information to propose a solution here

level 1

LAN (Local Area Networks) are separated at layer 3 by routers and layer 2 by VLANs. Routing cannot work if you have 2 or 3 destinations for the same network. You will have ping failures. Networks are separated by the layer 3 devices and must be addressed accordingly for routing to work.

level 1

You need separate /24 networks addressed on the respective office LANs. Networks cannot span layer 3 devices.

level 1

If you have this topology in PacketTracer, I would run simulation mode and see where the packets get dropped. The problem could be inter-VLAN routing, or something else.

Run show ip route from the router and see if it has a route to the network that you want to get to. If the route doesn’t exist, then packets will never get there.

Another question: what reason are you using rip for?

level 1

Can you post a trace output?

level 2
Original Poster0 points · 2 months ago

Office3>trace 192.168.1.2

Type escape sequence to abort.

Tracing the route to 192.168.1.2

1 10.0.0.1 4 msec 0 msec 0 msec

2 10.0.0.1 4 msec 4 msec 4 msec

level 1

What response are you getting from the host? Can you ping other devices on the same network as the printer? Can you ping any remote networks from the host?

level 2
Original Poster1 point · 2 months ago

I can ping the printer on the same network, but not on the other office network.

Office3>ping 192.168.3.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.3.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/17/72 ms

level 3

Yeah, you're asking about the remote network though. So that's what I'm asking about. When you ping from the host to the remote printer, what is the response? Can you ping any other remote device from the host?

You've already stated that you can ping the printer from the router, so the issue is the route from the host network to the printers network. The most obvious answer is the default gateway on the host is wrong, hence asking about your ability to ping other remote networks.

level 4
Original Poster1 point · 2 months ago

The addresses we get sign by our router is:

IPv4: 192.168.3.x

Subnetmask: 255.255.255.0

Gateway: 192.168.3.1

level 1

Can you also show the output of the remote router please;)

level 2
Original Poster1 point · 2 months ago

What router do you mean? The "office" routers of the backbone router?

level 1

Show run

level 2
Original Poster1 point · 2 months ago

Office3#sh run

Building configuration...

Current configuration : 1432 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Office3

!

boot-start-marker

boot system flash:c1700-advsecurityk9-mz.124-13b.bin

boot system slot1:c1700-advsecurityk9-mz.124-13b.bin

boot-end-marker

!

!

no aaa new-model

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.3.2

!

ip dhcp pool office3

import all

network 192.168.3.0 255.255.255.0

default-router 192.168.3.1

dns-server 8.8.8.8

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0

ip address 10.0.0.3 255.0.0.0

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface Vlan1

ip address 192.168.3.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Async1

no ip address

encapsulation slip

!

router rip

network 192.168.3.0

!

ip route 0.0.0.0 0.0.0.0 FastEthernet0 10.0.0.4

ip route 192.168.1.0 255.255.255.0 10.0.0.1

ip route 192.168.1.0 255.255.255.0 Vlan1 10.0.0.1

ip route 192.168.1.2 255.255.255.255 10.0.0.1

ip route 192.168.2.2 255.255.255.255 10.0.0.2

!

no ip http server

no ip http secure-server

ip nat inside source list 1 interface FastEthernet0 overload

!

access-list 1 permit any

!

control-plane

!

!

line con 0

line 1

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

login

!

end

level 1

So you are trying to ping a device on the same LAN? That’s the same router (local router). Can you show run the remote router?

level 2

hey so I might just be dumb, but what is a remote router?

level 2
Original Poster1 point · 2 months ago

Im not trying to ping a device on the same LAN, im trying to ping a other device on another LAN in the same network

From Office 3 to 2 (see image: https://imgur.com/a/rPHE92A)

level 1

Both Office3

level 2
Original Poster1 point · 2 months ago

Each Office should have 1 printer, where the office is able to print

They should be able to print across the Offices

Backbone:

Network: 10.0.0.0

Default gateway: 10.0.0.4

IP to internet/school backbone: DHCP (We get IP: 192.168.1.90)

Office 1:

Backbone IP: 10.0.0.1

LAN network : 192.168.1.0

Office Printer IP: 192.168.1.2

Able to print on: Office 3

Office 2:

Backbone IP: 10.0.0.2

LAN network : 192.168.2.0

Office Printer IP: 192.168.2.2

Able to print on: Office 1

Office 3:

Backbone IP: 10.0.0.3

LAN network : 192.168.3.0

Office Printer IP: 192.168.3.2

Able to print on: Office 2

This configuration is visually displayed here: https://imgur.com/a/rPHE92A

This network works 100% in Cisco Packet Tracer.

-----

Problem:

We are not able to ping remote hosts from LANs. Eg.: If we are on an Office 1 HOST and want to PING the Office 3 Printer (192.168.3.2), we get a timeout. From the HOST on Office 1 we can ping:

192.168.1.2 (Our printer)

10.0.0.4 (Backbone Router)

10.0.0.3 (Office 3 network)

We just can't get through to router to the remote printer, or the response isn't coming back to us.

Backbone router running-config: https://gist.github.com/rasmus0201/e49da4b0b1f28898872f7d2f7fb89b4f

Office 1 running-config: https://gist.github.com/rasmus0201/594bcd34c6e4437592bbb12d9bc13638

Office 2 running-config: https://gist.github.com/rasmus0201/945bdded0b2d009c243e4812d454dbef

Office 3 running-config: https://gist.github.com/rasmus0201/23ccec86ed464ce75662449474f7b844

We appreciate any help! :)

level 3

Can you ping from host to host in different lans?

level 4
Original Poster1 point · 2 months ago

No i cant.

level 5

Can you export the packet tracer file and upload it and send me the link, I will have it working in 10 minutes that way;)

level 5

Firstly the default gateway is incorrect on the printer

level 5

Should be 2.1

level 5

2nd the office 2 router has no route back to office 3

You need to add on office2 ip route 192.168.3.0 255.255.255.0 10.0.0.4

And remove the ip route 192.168.1.2 255.255.255.255 route and replace it with ip route 192.168.1.0 255.255.255.0 10.0.0.4

level 1

Can you export the packet tracer file and upload it somewhere, it’s really hard to troubleshoot like this;)

level 2
Original Poster1 point · 2 months ago
level 3
Original Poster1 point · 2 months ago

This is the working simulation of the project

level 1

Solved;)

level 2
Original Poster1 point · 2 months ago

The Packet Tracer project, did work as i should. We only have problem in the real life and not in the program.

level 1

What you also need to do is add ip static routes to each of the routers internal networks on their respective routers. You will then have full connectivity

level 1

The problem you have is the routers know where to send but they don’t know how to send back. Basically black hole routing;)

Good luck lads;)

level 2
Original Poster1 point · 2 months ago

Look at the configs from the real life routers, not the packet tracer.

Could you otherwise send it back via wetransfer?

Community Details

34.0k

Subscribers

225

Online

Create Post
r/ccna Rules
1.
No posting of illegal materials
2.
No posting of braindumps
3.
Be courteous and helpful
4.
Don't ask others to complete your labs
Cookies help us deliver our Services. By using our Services or clicking I agree, you agree to our use of cookies. Learn More.