Press J to jump to the feed. Press question mark to learn the rest of the keyboard shortcuts
4

Dear all,

We drew straws at work today, we needed an additional CCNP R&S for partner/contract compliancy.
Sadly, I lost and have accepted i'll go for CCNP. I've always appreciated the Reddit communities around Cisco certifications, so i'll definetly be lurking a lot and hopefully post occassionaly.

I know the CCNP ROUTE exam is a complete pain. I was therefore contemplating wether to start with SWITCH instead. I feel like if I got an easy win, it might further motivate me to study for the ROUTE exam. This is not to say that the SWITCH exam is a piece of cake, but it's arguably a lot better and practical than ROUTE in my opinion.

I am however not sure if this is a smart approach. I don't know if there are dependencies between ROUTE and SWITCH?
I've asked around but nobody really seems to know, everyone always starts off with ROUTE.

Does anyone have some experience with taking SWITCH before ROUTE?

Kind regards,

4
6 comments
7

I want to learn BGP in depth to crack interviews at big 4 companies. Where would be a good place to start and would be great if you can share some links.

I am all up to date with CBT, INE, Cisco Papers but in interviews they end up asking more, especially as the RPs are converging to BGP only, and I feel like it’s high time I master BGP.

7
13 comments
2

Hey guys, I am thinking about a move from NY to Austin but am worried about the salary differences. What do you guys make with a CCNP and do you work at a startup or larger company?

In NY it is common for a CCNP to make 100k+.

Thanks!

2
3 comments
19

So finally, on my third attempt, I passed 300-101.

I used:

  • Udemy
  • On the job experience
  • GNS3 for labbin

My study was very stop/start. I got a bit too anxious for the pay rise promised to me and decided to sit the exam in a rush. I put a bit too much faith in my work experience being able to get me over the line.

You still need to know finicky little things that you don't really use in day-to-day as well as commit things to memory that you have ready access to normally.

I thought the sims were pretty good. They reflected stuff you'd find out in the wild and weren't super obscure like some that I've seen in the past.

Just Tshoot left to go. I'll put a more concerted effort into consistent study this time.

Good luck peeps.

19
19 comments
22

I’m official! Test was fair and within the exam objectives. I studied the topology more than anything. That is the key to getting through this test. I’m a network admin and passed my first ccnp in 2010. This is a difficult test, but doable if you have any tshoot experience and are familiar with the exam objectives.

22
13 comments
11

Hi all.

I have almost finished the study for the CCNP Route exam.

For study I used the official Cisco Press book, along with Udemy and CBT nuggets.

To gain more confidence, would I be better using Boson ExSim or VCE Exam Simulator? Does anyone know the difference if any?

Is Boson a 1 for 1 of the real exam questions or is it similar to the Practice exams you get with the Cisco Press software (Pearson IT Certification Practice Test)?

11
11 comments
21

Passed the CCNP Switch recently.

Resources used:

  • Official Cert Guide
  • INE CCNP boot camp (Switch topics)
  • Boson Exam Simulator
  • 3750 config guide

Hitting the submit button at the end was harrowing, since I thought I was going to fail. The breadth of topics was more my issue than the individual topics themselves if that makes sense. Which is the same issue I had with the ICND1 v ICND2.

Make sure to hit the exam topics to make sure you feel comfortable with each of the topics listed, both from an understanding of how they work and how to implement them. This isn’t an entry level exam.

21
5 comments
0

Hello friends im Iraqi refugee currently living in Jordan, Im wondering if any of you have already purchased the ccna and ccnp routing and switching materials from the INE site that could share it with me because I don’t have the money currently to buy them at the moment because of the hard situation that we been through so I hope that someone here would help so I can start my learning journey because I have passion for this field of study

Thank you all in advance and God bless you Regards Sarmad

0
4 comments
2

I have Cisco packet tracer, but noticed that advanced commands glbp, vrrp and channel-group are not available. Is it possible to update/upgrade packet tracer to support these commands? If not, what are people using for sims that has advanced command support? Thank you in advance.

2
8 comments
17

Failed it last week with 664/790 which was pretty crushing. I had the sim everyone complains about as question #1, couldn't get it to work properly and it totally rattled me for the rest of the exam so I ended up making a bunch of mistakes I realized as soon as I left the testing center.

Took it again today after making notes of questions that caught me off guard and diving into a deeper level of detail on some subjects such as CDP/LLDP, VSS, and STP features, as well as extensively labbing the two sims I had. I was very lucky to have received the same two sims again. I ended up getting the funky sim to work properly only to discover I had misconfigured something. I tried to fix the problem which only ended up breaking the damn sim again! I was sure I failed again because of this, so I was totally shocked to see that I scored a 907...

As for how I prepared, I began studying at the beginning of June. Studied on average 3 hours per weekday after work and 6 hours a day on weekends. Study materials as follows:

  • OCG
  • Chris Bryant Udemy course
  • 3750 Configuration Guide
  • Various notes that have been kindly posted by other candidates on this subreddit
  • Ethernuno blog (https://ethernuno.wordpress.com/)
  • Anki flash cards
  • Boson ExSim
  • 3x Catalyst 3750s for labbing

As others have mentioned, the 3750 Configuration Guide is the holy grail for this exam. No other sources really go into the errata and level of detail required to pass the exam. I did not find the OCG for SWITCH nearly as good as the CCNA.

Regarding Boson, the practice exam was of high quality and a very useful aid for preparing. In fact, the Boson sims are of much higher quality than the actual Cisco sims (although that bar is set pretty low). That being said, I didn't think it gave an accurate picture of the level of detail needed to pass the exam, or a reliable gauge of if someone is ready for the actual exam. In hindsight I would have been better suited to use it just as a study-aid rather than "if I can pass these I can pass the real thing!" After my failure I requested a refund as part of their "no pass, no pay" guarantee, which they processed with no questions asked (other than providing proof of the fail). I will happily buy Boson's products again when I'm ready to prepare for ROUTE, but I would just suggest that they maybe throw a few more curve-balls and obscure questions onto the SWITCH exam.

Thanks very much to all the posters on here answering questions and sharing their experiences. I'm certain I could not have passed today without your collective advice. Feel free to let me know if you have any questions and I'll be happy to answer within the constraints of the NDA, of course.

17
4 comments
25

Used Udemy videos and book, the 3750 config guide and my old 642 switch book. Also used boson exsim. I created a one note with all the exam topics and documented everything. Just scheduled tshoot for Monday!

25
12 comments
9

Just wondering if anyone thinks Cisco will extend CCEP to CCNP. It would really make my life easier during the renewal process since I’m in deployed areas off and on.

9
6 comments
11

I can't for the love of learning fully understand CEF for the switch exam in 2 months! I feel I understand the basics:

It uses hardware to switch/forward data instead of software. Makes use of FIB (scaled down version of the routing table) and Adjacency table (scaled down Mac address table) to make forwarding decisions usually on longest prefix first. If a next hop address can't be found, it gets punted to the CPU for processing and look up from the Route Processor (working in software now?) Then this updates the FIB so data can continue being forwarded at line rate.

That's what I think of CEF. Please feel free to correct me. We're all here to learn and I would really love to fully grasp this concept.

Thanks!

11
9 comments
4

As the title says, I want to implement a new switch for my switch lab studies. It so happens that's it's used 3850 which runs IOS-xe. Can anyone say if both variants of IOS have similar syntax or vastly different?

Thank you!

4
17 comments
3

Hey guys,

I'm trying to run ebgp between 2 routers R2 and ISP2. For some reason, I keep getting the following message after I complete both ebgp configs from both routers. Here is my lab setup:

https://i.imgur.com/lLqh5pQ.jpg

R2:

*Aug  5 15:00:57.549: %BGP-3-NOTIFICATION: sent to neighbor 2.2.2.2 passive 2/3 (BGP identifier wrong) 4 bytes 02020202
R2#sh ip b
*Aug  5 15:00:52.492: %BGP-3-NOTIFICATION: received from neighbor 2.2.2.2 active 2/3 (BGP identifier wrong) 4 bytes 02020202
*Aug  5 15:00:57.549: %BGP-4-MSGDUMP: unsupported or mal-formatted message received from 2.2.2.2:
FFFF FFFF FFFF FFFF FFFF FFFF FFFF FFFF 0039 0104 012C 00B4 0202 0202 1C02 0601
0400 0100 0102 0280 0002 0202 0002 0246 0002 0641 0400 0001 2Cgp s

ISP2:

*Aug  5 15:11:09.690: %BGP-4-MSGDUMP: unsupported or mal-formatted message received from 22.22.22.22:
FFFF FFFF FFFF FFFF FFFF FFFF FFFF FFFF 0039 0104 01F4 00B4 0202 0202 1C02 0601
0400 0100 0102 0280 0002 0202 0002 0246 0002 0641 0400 0001 F4

I have eBGP configured as the following.

ISP2:

router bgp 300
neighbor 22.22.22.22 remote-as 500
neighbor 22.22.22.22 description NL ISP - R2
neighbor 22.22.22.22 update-source lo0
neighbor 22.22.22.22 ebgp-multihop 2

R2:

router bgp 500
neighbor 2.2.2.2 remote-as 300
neighbor 2.2.2.2 description UPLINK ISP2
neighbor 2.2.2.2 update-source lo0
neighbor 2.2.2.2 ebgp-multihop 2

I used Static routes on both R2 & ISP2 to point to eachothers loopbacks and have confirmed that I can ping eachothers loopbacks.

Really confused as this exact same config worked between R1 & ISP1.

Anyone come across this or can see a hole in my config that I'm missing?

Thanks!

EDIT:

Config for R2:

R2#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         180.1.5.6       YES NVRAM  up                    up
GigabitEthernet0/1         180.1.5.2       YES NVRAM  up                    up
GigabitEthernet0/2         10.1.1.6        YES NVRAM  up                    up
GigabitEthernet0/3         10.1.1.9        YES NVRAM  up                    up
Loopback0                  22.22.22.22     YES manual up                    up

R2#sh run | i ip route
ip route 2.2.2.2 255.255.255.255 180.1.5.1
ip route 2.2.2.2 255.255.255.255 180.1.5.5

R2#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/16/24 ms

Config for ISP2:

ISP2#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         180.1.5.5       YES NVRAM  up                    up
GigabitEthernet0/1         180.1.5.1       YES NVRAM  up                    up
GigabitEthernet0/2         unassigned      YES NVRAM  administratively down down
GigabitEthernet0/3         unassigned      YES NVRAM  administratively down down
Loopback0                  2.2.2.2         YES manual up                    up

ISP2#sh run | i ip route
ip route 22.22.22.22 255.255.255.255 180.1.5.2
ip route 22.22.22.22 255.255.255.255 180.1.5.6

ISP2#ping 22.22.22.22
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 7/21/47 ms
3
3 comments
5

i am using OCG and Kevin Wallace complete course with Chris as well for backup - just finished the whole syallabus once with OCG and Kevin's complete video course (excellent to use!) (took me 2 weeks to get through it all using every moment i had in and out of work - going to book the exam in 2 weeks time ish and go through all the pain points again!

a big tip for everyone - use Safaribooksonline and search for all your CCNP RELATED books! free 7 day trial and you can just create new emails to keep reading where you left off!

i swear by them as its an awesome resource to have!

time to go through Switch once more with Chris B now!

5
6 comments
29

Seriously thought I was going to fail after the first sim took me 48 minutes to complete but I did it!

Materials Used:

Chris Bryant CCNP Switch Udemy course

Chris Bryant CCNP Switch study guide

CCNP Switch book

Youtube

Work experience

Packet Tracer (no labs)

29
18 comments
5

Hello ppl of reddit,

I need some career advice. Story of my life in nutshell: I was attempting uni (computer science), but i have not graduated, after i was doing all kind of low level job (cleaner, fork-lift driver, waiter...) then i got fed up and once a friend of mine (CCIE) suggested to start learning cisco. I did. I wanted to work in security, but first things first, need the fundamentals and i did ccna r&s. After i was looking for a job, but i quit and change again and change again and now i am at about to change again and im not sure what would be the smartest move right now.

First i got a network designer job in an SSC, this was too boring, no technical tasks. Standard designs, mostly worked in excel and visio. (about a year)

Then i got a junior pen-tester job (lower job grade as network designer), which was very cool, but the management was trying to fight the fire in a burning building with a cup of water...it was a mess and too much headache. So less value i could extract there. Basically we were reporting stock web app issues... (9 months)

Then i changed to system verification job (R&D). Basically i have to support my colleagues in a data center environment. Configuring underlay network and testing (regression,sanity) switch firmware, (in security aspect as well, but that is just a very small slice), reproducing customer issues and solving them. ( Trial period will end soon)

I got two offers:

One is a Cyber Threat Defence Analyst, which is an real-time, eye on glass job, where we need to review SIEM alerts and escalation by end users. Escalating anomalies.

The other is a network engineer. Operation and maintenance of global back bone, resolving trouble tickets, on call support (night and weekend), domain registration.

I am a CCNP R&S and CCNA Cyber Ops and so close to OSCP.

What would you do? Stay at the data center where probably SD network will be the direction OR regular network engineering where later on i could try the ccie OR go for cyber cybersecurity, which is the closest to my heart?

I am a little afriad of the cyber threat job, because probably it is just staring at various displays (which is boring AF) but if there is chance to grow and in 1-2 years doing some interesing jobs in a SOC (if there is...) then it worth the suffer...but i have to stop jumping from job to job.

What would be a reasonable decision here? What would you do guys? Any advice with a bit of reasons? (31 yrs old with family)

5
5 comments
0

I'm just wondering if it is too late for me to start studying for the RS 300's? Any insight would be greatly appreciated!

0
6 comments
26

So its done, thank god hahha

Feels great to finally be done with all the stuying and testing and just say that i have acchived my goal of becoming a CCNP.

I little background about me, i started in ISP NOC about 6 years ago, after a stint there i moved on to Consultant with fokus on enterprise.

I got my CCNA in 2017 AUG but before this i already had my Juniper JNICP-ENT which i got in 2016.

I then got my CCNP switch in Febu and just a few months after i did Route.

i failed Route the first time because i was just not well prepard, and after a few weeks i passed.

Then last night i passed Tshoot.

I used the offical Cisco books for the CCNP. INE videos which are amazing for the CCNP track.

As well as a huge lab.

For anyone how just got there CCNA and wanna go on to CCNP, dont forgot that there are alot of things to do before the CCNP Track. Like SP och SEC track etc which can be a great path up to CCNP.

For me right now im gonna relax and then sometime end of next year get my CCDA so that i someday can do ARCH and get my CCDP.

Thank you !!!

26
9 comments
10

I’ve been studying since early March having lost motivation for brief periods. All in all the questions were fair and on-topic although I hope they get rid of FR when they refresh someday. On to the SWITCH exam!

Materials used:

  • Cisco Press OCG for Route and Switch for some topics not covered in the Route book
  • Chris Bryant’s Udemy CCNP All-in-one video boot camp
  • Boson Netsim
  • Boson Exsim
  • GNS3
  • Cisco documentation
10
15 comments
9

Anyone know if the topology (available here) is the same in terms of interface numbers and IP addresses? I'm looking to memorize it for when I sit the exam on Saturday so I don't have to keep jumping around the exam interface as much.

9
6 comments
4

I know, I should probably make my own. I have been googling and I am looking for a summary view of all of the features of each of the routing protocols for 300-101 to memorize. Anyone know of anything like that?

4
5 comments
0

Hi, I have the CCNA r&s and i want to study for the CCNP but i don't know where to study. What is the best method or course to pass the exam?

0
2 comments
2

Hey everyone, I have a question. Currently I'm studying for my switch exam (1st of the 3). I've watched the videos (INE) and almost through the book(OCG). It's time to now lab and lab (official lab manual). I have a rack setup with 4 switches (2x 3750, 2x 2960) that I'll be using. I also have a 2511 access server to make configurations easier.

The problem is, I'll be traveling out of two for a few weeks and won't be physically there to lab. How would I have to configure my home network to allow access to the terminal server while on the go? My public address is DHCP from the ISP and i have no access to the modem box provided to me. So it won't be as simple as enabling port forwarding to the interface connected to the modem.

Thanks!

2
9 comments
Community Details

6.2k

Subscribers

36

Online

Create Post
r/ccnp Rules
1.
No posting of illegal materials
2.
No posting of "braindumps"
3.
Be courteous and helpful
Cookies help us deliver our Services. By using our Services or clicking I agree, you agree to our use of cookies. Learn More.